aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 18 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 9c98f92..14f35f3 100644
--- a/setup.py
+++ b/setup.py
@@ -2,21 +2,25 @@
from setuptools import setup, find_packages
-setup(name='tpblite',
- version='0.1.3',
- description='The Unofficial Pirate Bay Lightweight Python API',
- author='Matt Lyon',
- author_email='matthewlyon18@gmail.com',
- python_requires='>=3.6',
- license='MIT License',
- packages=['tpblite', 'tpblite/models'],
- install_requires=[
+setup(name = 'tpblite',
+ version = '0.2.0',
+ description = 'The Unofficial Pirate Bay Lightweight Python API',
+ author = 'Matt Lyon',
+ author_email = 'matthewlyon18@gmail.com',
+ python_requires = '>=3.6',
+ url = 'https://github.com/mattlyon93/tpb-lite',
+ license = 'MIT License',
+ packages = ['tpblite', 'tpblite/models'],
+ install_requires = [
'beautifulsoup4',
- 'purl',
- ],
- classifiers=[
+ 'purl'],
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
'Programming Language :: Python',
'Operating System :: Unix',
- 'Operating System :: MacOS'
- ],
+ 'Operating System :: MacOS',
+ 'Topic :: Internet :: WWW/HTTP :: Browsers',
+ 'Topic :: Internet :: WWW/HTTP :: Indexing/Search',
+ 'Topic :: Utilities'],
+ keywords = ['ThePirateBay', 'PirateBay', 'torrent']
) \ No newline at end of file