aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatt Lyon <matthewlyon18@gmail.com>2019-12-17 22:50:56 +0000
committerMatt Lyon <matthewlyon18@gmail.com>2019-12-17 22:50:56 +0000
commitc7ec8249b8825a5d9226b16f6aa0c4e39d3d25cc (patch)
tree4e40a9229ff1525c0fc8ee5c7d633fef7ea9579d /setup.py
parentaa666a65a3c61fce8b103594cc432aaca2644b8e (diff)
downloadtpb-lite-c7ec8249b8825a5d9226b16f6aa0c4e39d3d25cc.tar.gz
tpb-lite-c7ec8249b8825a5d9226b16f6aa0c4e39d3d25cc.tar.bz2
tpb-lite-c7ec8249b8825a5d9226b16f6aa0c4e39d3d25cc.zip
updated README
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 18 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 9c98f92..14f35f3 100644
--- a/setup.py
+++ b/setup.py
@@ -2,21 +2,25 @@
from setuptools import setup, find_packages
-setup(name='tpblite',
- version='0.1.3',
- description='The Unofficial Pirate Bay Lightweight Python API',
- author='Matt Lyon',
- author_email='matthewlyon18@gmail.com',
- python_requires='>=3.6',
- license='MIT License',
- packages=['tpblite', 'tpblite/models'],
- install_requires=[
+setup(name = 'tpblite',
+ version = '0.2.0',
+ description = 'The Unofficial Pirate Bay Lightweight Python API',
+ author = 'Matt Lyon',
+ author_email = 'matthewlyon18@gmail.com',
+ python_requires = '>=3.6',
+ url = 'https://github.com/mattlyon93/tpb-lite',
+ license = 'MIT License',
+ packages = ['tpblite', 'tpblite/models'],
+ install_requires = [
'beautifulsoup4',
- 'purl',
- ],
- classifiers=[
+ 'purl'],
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
'Programming Language :: Python',
'Operating System :: Unix',
- 'Operating System :: MacOS'
- ],
+ 'Operating System :: MacOS',
+ 'Topic :: Internet :: WWW/HTTP :: Browsers',
+ 'Topic :: Internet :: WWW/HTTP :: Indexing/Search',
+ 'Topic :: Utilities'],
+ keywords = ['ThePirateBay', 'PirateBay', 'torrent']
) \ No newline at end of file