aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan@gmail.com>2011-08-23 16:46:16 -0400
committerWaylan Limberg <waylan@gmail.com>2011-08-23 16:46:16 -0400
commitb51f22daa98c8c484b48134fe5f1b19b7a6291c3 (patch)
tree43e9dcf9b80a4c496eb1adc1e16e72e098a8cc43 /setup.py
parenta4022d40d0437e777c54c91876045dee0932ee60 (diff)
downloadmarkdown-b51f22daa98c8c484b48134fe5f1b19b7a6291c3.tar.gz
markdown-b51f22daa98c8c484b48134fe5f1b19b7a6291c3.tar.bz2
markdown-b51f22daa98c8c484b48134fe5f1b19b7a6291c3.zip
Added support to build_docs command to copy non markdown files unmodified.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 80e9581..8a28341 100755
--- a/setup.py
+++ b/setup.py
@@ -120,6 +120,10 @@ class build_docs(Command):
doc = open(outfile, 'wb')
doc.write(out.encode('utf-8'))
doc.close()
+ else:
+ outfile = change_root(self.build_base, infile)
+ self.mkpath(os.path.split(outfile)[0])
+ self.copy_file(infile, outfile)
class md_build(build):