aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan@gmail.com>2011-08-23 11:23:28 -0400
committerWaylan Limberg <waylan@gmail.com>2011-08-23 11:23:28 -0400
commita4022d40d0437e777c54c91876045dee0932ee60 (patch)
treefbb694a256d5dd571d96048ee7269304146dd2a2 /setup.py
parenta6fd7b5cba69cad049046b3a372d0f2d6c495abe (diff)
downloadmarkdown-a4022d40d0437e777c54c91876045dee0932ee60.tar.gz
markdown-a4022d40d0437e777c54c91876045dee0932ee60.tar.bz2
markdown-a4022d40d0437e777c54c91876045dee0932ee60.zip
Update build_docs script for the *.txt -> *.md change in docs.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 1 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 6f119bb..80e9581 100755
--- a/setup.py
+++ b/setup.py
@@ -67,12 +67,6 @@ class build_docs(Command):
('build_base', 'build_base'),
('force', 'force'))
self.docs = self._get_docs()
- try:
- sm = open('docs/sitemap.txt')
- self.sitemap = sm.read()
- sm.close()
- except:
- pass
def _get_docs(self):
for root, dirs, files in os.walk('docs'):
@@ -106,11 +100,9 @@ class build_docs(Command):
else:
template = codecs.open('docs/_template.html', encoding='utf-8').read()
md = markdown.Markdown(extensions=['extra', 'toc'])
- menu = md.convert(self.sitemap)
- md.reset()
for infile, title in self.docs:
outfile, ext = os.path.splitext(infile)
- if ext == '.txt':
+ if ext == '.md':
outfile += '.html'
outfile = change_root(self.build_base, outfile)
self.mkpath(os.path.split(outfile)[0])