aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..4df49d6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python3
+
+from setuptools import setup, find_packages
+
+setup(name='tpblite',
+ version='0.1.0',
+ description='The Unofficial Pirate Bay Lightweight Python API',
+ author='Matt Lyon',
+ author_email='matthewlyon18@gmail.com',
+ python_requires='>=3.6',
+ license='MIT License',
+ packages=['tpblite', 'tpblite/models'],
+ install_requires=[
+ 'beautifulsoup4',
+ 'purl',
+ ],
+ classifiers=[
+ 'Programming Language :: Python',
+ 'Operating System :: Unix',
+ 'Operating System :: MacOS'
+ ],
+ ) \ No newline at end of file