aboutsummaryrefslogtreecommitdiffstats
path: root/.gitattributes
diff options
context:
space:
mode:
authorjim-p <jimp@pfsense.org>2012-12-10 11:21:30 -0500
committerjim-p <jimp@pfsense.org>2012-12-10 11:21:30 -0500
commitcb2601be772d7529abd11377e6b1095b2e06d252 (patch)
tree95d72466d466eb8f68d4a97a43e78a40c09bfdf1 /.gitattributes
parent1b4340d70cf72a5b182c5a3c9e7859a20eeb16a7 (diff)
downloadpfsense-packages-cb2601be772d7529abd11377e6b1095b2e06d252.tar.gz
pfsense-packages-cb2601be772d7529abd11377e6b1095b2e06d252.tar.bz2
pfsense-packages-cb2601be772d7529abd11377e6b1095b2e06d252.zip
Add .gitattributes file to help maintain proper newlines.
Diffstat (limited to '.gitattributes')
-rw-r--r--.gitattributes46
1 files changed, 46 insertions, 0 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 00000000..5a0d4bb4
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1,46 @@
+# Using default template from https://help.github.com/articles/dealing-with-line-endings with modifications.
+# Set default behaviour, in case users don't have core.autocrlf set.
+* text=auto
+
+# Explicitly declare text files we want to always be normalized and converted
+# to native line endings on checkout.
+*.c text
+*.h text
+*.php text
+*.inc text
+*.sh text
+*.h text
+*.md5 text
+*.sha256 text
+*.conf text
+*.xml text
+*.ovf text
+*.css text
+*.htm* text
+*.js text
+*.diff text
+*.patch text
+*.pl text
+*.rules text
+*.txt text
+rc.* text
+*.sql text
+*.mk text
+
+# Files that will always have CRLF line endings on checkout. (Not sure we have any of these)
+# *.dos text eol=crlf
+
+# Denote all files that are truly binary and should not be modified.
+*.png binary
+*.jpg binary
+*.gif binary
+*.so* binary
+*.gz binary
+*.tgz binary
+*.exe binary
+*.ico binary
+*.img binary
+*.zip binary
+*.uzip binary
+*.tar binary
+*.ttf binary \ No newline at end of file