aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan@gmail.com>2012-03-07 09:35:40 -0500
committerWaylan Limberg <waylan@gmail.com>2012-03-07 09:35:40 -0500
commitec46692cf5c4d5e22950bc8e7d14cb0ec327fb87 (patch)
tree9c1b9c5025948204e415a21938469bf50bbae754 /setup.py
parent9fd4a5f1600c96406ad0fb86b1a8287d525972ac (diff)
downloadmarkdown-ec46692cf5c4d5e22950bc8e7d14cb0ec327fb87.tar.gz
markdown-ec46692cf5c4d5e22950bc8e7d14cb0ec327fb87.tar.bz2
markdown-ec46692cf5c4d5e22950bc8e7d14cb0ec327fb87.zip
Rename docs/*.md => docs/*.txt
The documentation uses features of Python-Markdown that are not supported on GitHub and it's better to get a source view of the docs anyway. For example, that way comments and bug reports can reference a specific line of a file. Of course, it makes sense for Github to render the README, so that is left with the `.md` file extension.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8bb0b22..0fe2751 100755
--- a/setup.py
+++ b/setup.py
@@ -130,7 +130,7 @@ class build_docs(Command):
self.md = markdown.Markdown(extensions=['extra', 'toc', 'meta'])
for infile in self.docs:
outfile, ext = os.path.splitext(infile)
- if ext == '.md':
+ if ext == '.txt':
# Copy src to .txt file
srcfile = outfile + '.txt'
srcfile = change_root(self.build_base, srcfile)