aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan@gmail.com>2013-02-27 09:10:47 -0500
committerWaylan Limberg <waylan@gmail.com>2013-02-27 09:10:47 -0500
commit579288c5eb684dd09d1ef298929a566f40151205 (patch)
treed10a50f91b8606cd1dea38764168abab92958b0f /setup.py
parentb37ab16ba56ac6fe4e64f87521996bad323058f2 (diff)
downloadmarkdown-579288c5eb684dd09d1ef298929a566f40151205.tar.gz
markdown-579288c5eb684dd09d1ef298929a566f40151205.tar.bz2
markdown-579288c5eb684dd09d1ef298929a566f40151205.zip
Now using universal code for Python 2 & 3.
The most notable changes are the use of unicode_literals and absolute_imports. Actually, absolute_imports was the biggest deal as it gives us relative imports. For the first time extensions import markdown relative to themselves. This allows other packages to embed the markdown lib in a subdir of their project and still be able to use our extensions.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index b244b64..140a0ae 100755
--- a/setup.py
+++ b/setup.py
@@ -10,14 +10,6 @@ from distutils.util import change_root, newer
import codecs
import imp
-# Try to run 2to3 automaticaly when building in Python 3.x
-try:
- from distutils.command.build_py import build_py_2to3 as build_py
-except ImportError:
- if sys.version_info >= (3, 0):
- raise ImportError("build_py_2to3 is required to build in Python 3.x.")
- from distutils.command.build_py import build_py
-
def get_version():
" Get version & version_info without importing markdown.__init__ "
path = os.path.join(os.path.dirname(__file__), 'markdown')
@@ -235,7 +227,6 @@ setup(
packages = ['markdown', 'markdown.extensions'],
scripts = ['bin/%s' % SCRIPT_NAME],
cmdclass = {'install_scripts': md_install_scripts,
- 'build_py': build_py,
'build_docs': build_docs,
'build': md_build},
classifiers = ['Development Status :: %s' % DEVSTATUS,