aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan.limberg@icloud.com>2014-08-27 13:34:19 -0400
committerWaylan Limberg <waylan.limberg@icloud.com>2014-08-27 13:34:19 -0400
commit44e718ed82ed4c8e8e0f0fe1dbdb73d441747b19 (patch)
tree4006dad4eb9fa86169ededd817ede082bf720270 /setup.py
parent8c29487fe973f9007510dd6c4f32083b8d4d0896 (diff)
downloadmarkdown-44e718ed82ed4c8e8e0f0fe1dbdb73d441747b19.tar.gz
markdown-44e718ed82ed4c8e8e0f0fe1dbdb73d441747b19.tar.bz2
markdown-44e718ed82ed4c8e8e0f0fe1dbdb73d441747b19.zip
Refactored extension importing.
We now use importlib which means we no longer support Python 2.6. Also, this refactor properly imports third party extensions which reside at the root of PYTHONPATH. Previously, either `markdown.extensions.` or `mdx_` would be appended to any extension name that did not contain a dot, which required third party extensions to either be in submodules or use the old `mdx_` naming convention. This commit is also in preperation for #336. It will now be much easier to deprecate (and later remove) support for the old ways of handling extension names.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 568e8c5..f635b48 100755
--- a/setup.py
+++ b/setup.py
@@ -235,7 +235,6 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',