aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDmitry Shachnev <mitya57@gmail.com>2012-09-09 17:24:22 +0400
committerDmitry Shachnev <mitya57@gmail.com>2012-09-09 17:24:22 +0400
commit13fa0847ab676ee2975403cefdb25f2d5395f4ad (patch)
treeba6aa9ee697b1b99b22b0f30795bf0786bbecf2b /setup.py
parent8d84c356bdf27c40a2e694a3e50f44830b8c6fd6 (diff)
downloadmarkdown-13fa0847ab676ee2975403cefdb25f2d5395f4ad.tar.gz
markdown-13fa0847ab676ee2975403cefdb25f2d5395f4ad.tar.bz2
markdown-13fa0847ab676ee2975403cefdb25f2d5395f4ad.zip
setup.py: Add `long_description` attribute to `data`
so that there's no text breakage on PyPI page
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3491300..e6fbdd7 100755
--- a/setup.py
+++ b/setup.py
@@ -165,6 +165,27 @@ class md_build(build):
sub_commands = build.sub_commands + [('build_docs', has_docs)]
+long_description = \
+'''This is a Python implementation of John Gruber's Markdown_.
+It is almost completely compliant with the reference implementation,
+though there are a few known issues. See Features_ for information
+on what exactly is supported and what is not. Additional features are
+supported by the `Available Extensions`_.
+
+.. _Python-Markdown: http://packages.python.org/Markdown/
+.. _Markdown: http://daringfireball.net/projects/markdown/
+.. _Features: http://packages.python.org/Markdown/index.html#Features
+.. _`Available Extensions`: http://packages.python.org/Markdown/extensions/index.html
+
+Support
+=======
+
+You may ask for help and discuss various other issues on the
+`mailing list`_ and report bugs on the `bug tracker`_.
+
+.. _`mailing list`: http://lists.sourceforge.net/lists/listinfo/python-markdown-discuss
+.. _`bug tracker`: http://github.com/waylan/Python-Markdown/issues
+'''
data = dict(
name = 'Markdown',
@@ -172,6 +193,7 @@ data = dict(
url = 'http://packages.python.org/Markdown/',
download_url = 'http://pypi.python.org/packages/source/M/Markdown/Markdown-%s.tar.gz' % version,
description = 'Python implementation of Markdown.',
+ long_description = long_description,
author = 'Manfred Stienstra, Yuri takhteyev and Waylan limberg',
author_email = 'markdown [at] freewisdom.org',
maintainer = 'Waylan Limberg',