aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan.limberg@icloud.com>2018-07-27 14:34:56 -0400
committerWaylan Limberg <waylan.limberg@icloud.com>2018-07-27 14:43:09 -0400
commit0081cb8519ebda441b129462e8eb6c0f6c7d30a4 (patch)
treec445ae13ad49aeff3634ffc42b17958e57d966ca /setup.py
parent25482261a494ad12c108435580ed13927bdc417c (diff)
downloadmarkdown-0081cb8519ebda441b129462e8eb6c0f6c7d30a4.tar.gz
markdown-0081cb8519ebda441b129462e8eb6c0f6c7d30a4.tar.bz2
markdown-0081cb8519ebda441b129462e8eb6c0f6c7d30a4.zip
Consistent copyright headers.
Fixes #435.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9614a49..c81e4f9 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,26 @@
#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+"""
+Python Markdown
+
+A Python implementation of John Gruber's Markdown.
+
+Documentation: https://python-markdown.github.io/
+GitHub: https://github.com/Python-Markdown/markdown/
+PyPI: https://pypi.org/project/Markdown/
+
+Started by Manfred Stienstra (http://www.dwerg.net/).
+Maintained for a few years by Yuri Takhteyev (http://www.freewisdom.org).
+Currently maintained by Waylan Limberg (https://github.com/waylan),
+Dmitry Shachnev (https://github.com/mitya57) and Isaac Muse (https://github.com/facelessuser).
+
+Copyright 2007-2018 The Python Markdown Project (v. 1.7 and later)
+Copyright 2004, 2005, 2006 Yuri Takhteyev (v. 0.2-1.6b)
+Copyright 2004 Manfred Stienstra (the original version)
+
+License: BSD (see LICENSE.md for details).
+"""
+
from setuptools import setup
from markdown import __version__, __version_info__