aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGeorge Hickman <george@ghickman.co.uk>2012-05-21 16:31:06 +0100
committerGeorge Hickman <george@ghickman.co.uk>2012-05-21 17:40:15 +0100
commit9fe90235c8fc41b2450fc585bbe57cfe92f69f7b (patch)
tree32510453a5122cff28c43a7f5d9982dfeec70f47 /setup.py
parentef5abef14a4baf7c136fe6d0bc3f687fc14800d1 (diff)
downloaddjango-wkhtmltopdf-9fe90235c8fc41b2450fc585bbe57cfe92f69f7b.tar.gz
django-wkhtmltopdf-9fe90235c8fc41b2450fc585bbe57cfe92f69f7b.tar.bz2
django-wkhtmltopdf-9fe90235c8fc41b2450fc585bbe57cfe92f69f7b.zip
Bump version to 0.3
* Tidy up the setup.py. * Remove the old `fread` method. * Make `__version__` a string. * Move `__author__` into __init__.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 9 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 9da3678..86c0b44 100644
--- a/setup.py
+++ b/setup.py
@@ -1,22 +1,17 @@
-from os.path import dirname, join
from setuptools import setup, find_packages
-from wkhtmltopdf import get_version
+import wkhtmltopdf
-def fread(fn):
- with open(join(dirname(__file__), fn), 'r') as f:
- return f.read()
-
setup(
- name = "django-wkhtmltopdf",
- packages = find_packages(),
+ name='django-wkhtmltopdf',
+ packages=find_packages(),
include_package_data=True,
- version = get_version(),
- description = "Converts html to PDF using http://code.google.com/p/wkhtmltopdf/.",
- long_description = fread('README.rst'),
- author = "Incuna Ltd",
- author_email = "admin@incuna.com",
- url = "http://incuna.com/",
+ version=wkhtmltopdf.__version__,
+ description='Converts html to PDF using http://code.google.com/p/wkhtmltopdf/.',
+ long_description=open('README.rst').read(),
+ author=wkhtmltopdf.__author__,
+ author_email='admin@incuna.com',
+ url='http://incuna.com/',
)