aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py76
1 files changed, 41 insertions, 35 deletions
diff --git a/setup.py b/setup.py
index cbfcaae..1224dd9 100755
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,8 @@
import sys, os
from distutils.core import setup
from distutils.command.install_scripts import install_scripts
-from markdown import version
+
+version = '2.0.3'
class md_install_scripts(install_scripts):
""" Customized install_scripts. Create markdown.bat for win32. """
@@ -23,39 +24,44 @@ class md_install_scripts(install_scripts):
except Exception, e:
print 'ERROR: Unable to create %s: %s' % (bat_path, e)
-setup(
- name = 'Markdown',
- version = version,
- url = 'http://www.freewisdom.org/projects/python-markdown',
- download_url = 'http://pypi.python.org/packages/source/M/Markdown/Markdown-%s.tar.gz'%version,
- description = "Python implementation of Markdown.",
- author = "Manfred Stienstra and Yuri takhteyev",
- author_email = "yuri [at] freewisdom.org",
- maintainer = "Waylan Limberg",
- maintainer_email = "waylan [at] gmail.com",
- license = "BSD License",
- packages = ['markdown', 'markdown.extensions', 'markdown.tests'],
- scripts = ['bin/markdown'],
- package_data = {'': ['tests/*/*.txt', 'tests/*/*.html', 'tests/*/*.cfg',
+data = dict(
+ name = 'Markdown',
+ version = version,
+ url = 'http://www.freewisdom.org/projects/python-markdown',
+ download_url = 'http://pypi.python.org/packages/source/M/Markdown/Markdown-%s.tar.gz' % version,
+ description = 'Python implementation of Markdown.',
+ author = 'Manfred Stienstra and Yuri takhteyev',
+ author_email = 'yuri [at] freewisdom.org',
+ maintainer = 'Waylan Limberg',
+ maintainer_email = 'waylan [at] gmail.com',
+ license = 'BSD License',
+ packages = ['markdown', 'markdown.extensions', 'markdown.tests'],
+ package_data = {'': ['tests/*/*.txt', 'tests/*/*.html', 'tests/*/*.cfg',
'tests/*/*/*.txt', 'tests/*/*/*.html', 'tests/*/*/*.cfg']},
- cmdclass = {'install_scripts': md_install_scripts},
- classifiers = ['Development Status :: 5 - Production/Stable',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.3',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.0',
- 'Topic :: Communications :: Email :: Filters',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
- 'Topic :: Internet :: WWW/HTTP :: Site Management',
- 'Topic :: Software Development :: Documentation',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Text Processing :: Filters',
- 'Topic :: Text Processing :: Markup :: HTML',
- ],
+ scripts = ['bin/markdown'],
+ cmdclass = {'install_scripts': md_install_scripts},
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.3',
+ 'Programming Language :: Python :: 2.4',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.0',
+ 'Topic :: Communications :: Email :: Filters',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
+ 'Topic :: Internet :: WWW/HTTP :: Site Management',
+ 'Topic :: Software Development :: Documentation',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Text Processing :: Filters',
+ 'Topic :: Text Processing :: Markup :: HTML',
+ ],
)
+
+if sys.version[:3] < '2.5':
+ data['install_requires'] = ['elementtree']
+
+setup(**data)