diff options
author | Waylan Limberg <waylan@gmail.com> | 2012-09-09 16:45:24 -0700 |
---|---|---|
committer | Waylan Limberg <waylan@gmail.com> | 2012-09-09 16:45:24 -0700 |
commit | 0541e8e76f4ad2b8bfe302238eae85a77719e249 (patch) | |
tree | e14294308bb4139360280779b5fc39776e0f678b /setup.py | |
parent | 8d84c356bdf27c40a2e694a3e50f44830b8c6fd6 (diff) | |
parent | a3656333ea3f7b391b1b61c13e3566b4e0d81053 (diff) | |
download | markdown-0541e8e76f4ad2b8bfe302238eae85a77719e249.tar.gz markdown-0541e8e76f4ad2b8bfe302238eae85a77719e249.tar.bz2 markdown-0541e8e76f4ad2b8bfe302238eae85a77719e249.zip |
Merge pull request #142 from mitya57/master
Add `long_description` attribute to `data` in `setup.py`
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 21 |
1 files changed, 21 insertions, 0 deletions
@@ -165,6 +165,26 @@ class md_build(build): sub_commands = build.sub_commands + [('build_docs', has_docs)] +long_description = \ +'''This is a Python implementation of John Gruber's Markdown_. +It is almost completely compliant with the reference implementation, +though there are a few known issues. See Features_ for information +on what exactly is supported and what is not. Additional features are +supported by the `Available Extensions`_. + +.. _Markdown: http://daringfireball.net/projects/markdown/ +.. _Features: http://packages.python.org/Markdown/index.html#Features +.. _`Available Extensions`: http://packages.python.org/Markdown/extensions/index.html + +Support +======= + +You may ask for help and discuss various other issues on the +`mailing list`_ and report bugs on the `bug tracker`_. + +.. _`mailing list`: http://lists.sourceforge.net/lists/listinfo/python-markdown-discuss +.. _`bug tracker`: http://github.com/waylan/Python-Markdown/issues +''' data = dict( name = 'Markdown', @@ -172,6 +192,7 @@ data = dict( url = 'http://packages.python.org/Markdown/', download_url = 'http://pypi.python.org/packages/source/M/Markdown/Markdown-%s.tar.gz' % version, description = 'Python implementation of Markdown.', + long_description = long_description, author = 'Manfred Stienstra, Yuri takhteyev and Waylan limberg', author_email = 'markdown [at] freewisdom.org', maintainer = 'Waylan Limberg', |