aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWaylan Limberg <waylan@gmail.com>2009-02-04 18:12:16 -0500
committerWaylan Limberg <waylan@gmail.com>2009-02-04 18:12:16 -0500
commitbfaa7e176687865b46cf10a56168765d181a0099 (patch)
treee161590d1fac3c346ad4c493ba802c10130cf4d3 /setup.py
parent0f6ff94aed8c2f6529d2308f75a770f2b130bff9 (diff)
downloadmarkdown-bfaa7e176687865b46cf10a56168765d181a0099.tar.gz
markdown-bfaa7e176687865b46cf10a56168765d181a0099.tar.bz2
markdown-bfaa7e176687865b46cf10a56168765d181a0099.zip
Added some more meta-data to setup.py. Shouldn't have to manually edit pypi page anymore.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f840b62..078a535 100755
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,8 @@ from distutils.core import setup
setup(
name = 'Markdown',
version = '2.0-beta-2',
+ url = 'http://www.freewisdom.org/projects/python-markdown',
+ download_url = 'http://pypi.python.org/packages/source/M/Markdown/markdown-1.7.tar.gz',
description = "Python implementation of Markdown.",
author = "Manfred Stienstra and Yuri takhteyev",
author_email = "yuri [at] freewisdom.org",
@@ -14,4 +16,16 @@ setup(
license = "BSD License",
packages = ['markdown', 'markdown.extensions'],
scripts = ['markdown.py'],
+ classifiers = ['Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Communications :: Email :: Filters',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
+ 'Topic :: Internet :: WWW/HTTP :: Site Management',
+ 'Topic :: Software Development :: Documentation',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Text Processing :: Filters',
+ 'Topic :: Text Processing :: Markup :: HTML',
+ ],
)