diff options
author | Michał Górny <mgorny@gentoo.org> | 2013-01-13 10:13:21 +0100 |
---|---|---|
committer | Michał Górny <mgorny@gentoo.org> | 2013-01-13 10:13:21 +0100 |
commit | ff80e467ea875e4677fcc20c189ef730ef240a07 (patch) | |
tree | daddb8f8443c8498efd124f26c72d0dbd48c12be /setup.py | |
parent | 4e65bb6b49f85a311aac0b6225b7520388486ff5 (diff) | |
download | markdown-ff80e467ea875e4677fcc20c189ef730ef240a07.tar.gz markdown-ff80e467ea875e4677fcc20c189ef730ef240a07.tar.bz2 markdown-ff80e467ea875e4677fcc20c189ef730ef240a07.zip |
Support disabling documentation build via --no-build-docs.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 13 |
1 files changed, 12 insertions, 1 deletions
@@ -183,8 +183,19 @@ class build_docs(Command): class md_build(build): """ Run "build_docs" command from "build" command. """ + + user_options = build.user_options + [ + ('no-build-docs', None, 'do not build documentation'), + ] + + boolean_options = build.boolean_options + ['build-docs'] + + def initialize_options(self): + build.initialize_options(self) + self.no_build_docs = False + def has_docs(self): - return True + return not self.no_build_docs sub_commands = build.sub_commands + [('build_docs', has_docs)] |