diff options
author | Waylan Limberg <waylan@gmail.com> | 2012-07-12 09:56:42 -0400 |
---|---|---|
committer | Waylan Limberg <waylan@gmail.com> | 2012-07-12 09:56:42 -0400 |
commit | f087887ab9d18d55c686da366fa3a23b303272a0 (patch) | |
tree | 1b5a92ee3c04cd53b9269927652c4b2fb4dabd78 /setup.py | |
parent | 34cb4827da7eee2310ab285110cdadfdfbc85993 (diff) | |
download | markdown-f087887ab9d18d55c686da366fa3a23b303272a0.tar.gz markdown-f087887ab9d18d55c686da366fa3a23b303272a0.tar.bz2 markdown-f087887ab9d18d55c686da366fa3a23b303272a0.zip |
Fixed #115. Make sure all file objects are closed.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -1,5 +1,6 @@ #!/usr/bin/env python +from __future__ import with_statement import sys, os from distutils.core import setup from distutils.command.install_scripts import install_scripts @@ -126,7 +127,8 @@ class build_docs(Command): except ImportError: print ('skipping build_docs: Markdown "import" failed!') else: - template = codecs.open('docs/_template.html', encoding='utf-8').read() + with codecs.open('docs/_template.html', encoding='utf-8') as f: + template = f.read() self.md = markdown.Markdown(extensions=['extra', 'toc', 'meta']) for infile in self.docs: outfile, ext = os.path.splitext(infile) @@ -144,7 +146,8 @@ class build_docs(Command): if self.verbose: print ('Converting %s -> %s' % (infile, outfile)) if not self.dry_run: - src = codecs.open(infile, encoding='utf-8').read() + with codecs.open(infile, encoding='utf-8') as f: + src = f.read() out = template % self._get_context(src, outfile) doc = open(outfile, 'wb') doc.write(out.encode('utf-8')) |