diff options
author | Waylan Limberg <waylan@gmail.com> | 2010-08-20 10:56:42 -0400 |
---|---|---|
committer | Waylan Limberg <waylan@gmail.com> | 2010-08-20 10:56:42 -0400 |
commit | dc63c6881893c0a518a4914c3f4622c5d9a25c93 (patch) | |
tree | dd145be21919db203fd83bc567885b86e0d53c3d /setup.py | |
parent | ad2e798a81d63de5e1822a489688b885ca412c96 (diff) | |
parent | 3bd36d4c8f0ca1f7345999a58d7b8c2f5e6f9fbe (diff) | |
download | markdown-dc63c6881893c0a518a4914c3f4622c5d9a25c93.tar.gz markdown-dc63c6881893c0a518a4914c3f4622c5d9a25c93.tar.bz2 markdown-dc63c6881893c0a518a4914c3f4622c5d9a25c93.zip |
Merge branch 'master' of git@gitorious.org:python-markdown/mainline
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -36,9 +36,10 @@ class md_install_scripts(install_scripts): f = file(bat_path, 'w') f.write(bat_str) f.close() - print 'Created:', bat_path - except Exception, e: - print 'ERROR: Unable to create %s: %s' % (bat_path, e) + print ('Created: %s' % bat_path) + except Exception: + _, err, _ = sys.exc_info() # for both 2.x & 3.x compatability + print ('ERROR: Unable to create %s: %s' % (bat_path, err)) class build_docs(Command): |