aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCharlie Denton <charleswdenton@gmail.com>2012-05-21 13:55:43 -0700
committerCharlie Denton <charleswdenton@gmail.com>2012-05-21 13:55:43 -0700
commita76af4820ce71e1b0fd0052f0cf39690a34b680c (patch)
tree32510453a5122cff28c43a7f5d9982dfeec70f47 /setup.py
parent4867d6bd6484c6bc1a263e49c3b08f3cfa30ff1d (diff)
parent9fe90235c8fc41b2450fc585bbe57cfe92f69f7b (diff)
downloaddjango-wkhtmltopdf-a76af4820ce71e1b0fd0052f0cf39690a34b680c.tar.gz
django-wkhtmltopdf-a76af4820ce71e1b0fd0052f0cf39690a34b680c.tar.bz2
django-wkhtmltopdf-a76af4820ce71e1b0fd0052f0cf39690a34b680c.zip
Merge pull request #6 from incuna/develop
Fix tmp_files & tidy up response object
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 9 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 9da3678..86c0b44 100644
--- a/setup.py
+++ b/setup.py
@@ -1,22 +1,17 @@
-from os.path import dirname, join
from setuptools import setup, find_packages
-from wkhtmltopdf import get_version
+import wkhtmltopdf
-def fread(fn):
- with open(join(dirname(__file__), fn), 'r') as f:
- return f.read()
-
setup(
- name = "django-wkhtmltopdf",
- packages = find_packages(),
+ name='django-wkhtmltopdf',
+ packages=find_packages(),
include_package_data=True,
- version = get_version(),
- description = "Converts html to PDF using http://code.google.com/p/wkhtmltopdf/.",
- long_description = fread('README.rst'),
- author = "Incuna Ltd",
- author_email = "admin@incuna.com",
- url = "http://incuna.com/",
+ version=wkhtmltopdf.__version__,
+ description='Converts html to PDF using http://code.google.com/p/wkhtmltopdf/.',
+ long_description=open('README.rst').read(),
+ author=wkhtmltopdf.__author__,
+ author_email='admin@incuna.com',
+ url='http://incuna.com/',
)